Az OpenShot videó szerkesztő alkalmazás telepítési lehetőségei (Linux Mint 19 Tara)

kimarite képe

Linux disztribúciók kapcsán, amikor videó szerkesztésről beszélünk, akkor rögtön a Kino, vagy az Avidemux jut az eszünkbe. Ezeken a szoftvereken kívül viszont megannyi megoldás kínálkozik a mozgóképekkel való munkára. Ezek között találunk profi alkalmazásokat, és olyat is ami a hétköznapi felhasználók számára is könnyen használható. Az egyik ilyen egyszerűen kezelhető, és számtalan funkcióval rendelkező, nem lineáris videó szerkesztő program, az OpenShot.
Forrás: http://www.gamechannel.hu/cikk/tuxvilaga/openshot_video_szerkeszto

Ha nem a Linux Mint 19 Tara kiadást használod, a tükrökről elérhető OpenShot, ugyanúgy a rendelkezésedre áll. A PPA verziókat viszont ellenőrizd a telepítés előtt, hogy elkészültek-e a rendszeredre a hozzávaló csomagok. A Linux Mint 18.x például az Ubuntu Xenial Xerus kiadásnak felel meg. Kérdezz bátran, ha valamit nem értesz.

Telepítés

Ha például a Linux Mint 19 Tara kiadást használod, úgy az OpenShot videó szerkesztő alkalmazás telepítése mindössze ennyi:

sudo apt-get install openshot

De ha a stabil PPA-t vennéd fel, a kicsit újabb csomagokkal,
(itt az eredmény látható, azaz a PPA-t már használatba vettem)

apt-cache policy openshot openshot-qt
openshot:
  Telepítve: 2.4.1-2build2
  Jelölt:    2.4.1-2build2
  Verziótáblázat:
 *** 2.4.1-2build2 500
        500 http://ftp.energotel.sk/pub/linux/ubuntu/archive bionic/universe amd64 Packages
        500 http://ftp.energotel.sk/pub/linux/ubuntu/archive bionic/universe i386 Packages
        100 /var/lib/dpkg/status
openshot-qt:
  Telepítve: 2.4.2+dfsg2+936+201806302357~ubuntu18.04.1
  Jelölt:    2.4.2+dfsg2+936+201806302357~ubuntu18.04.1
  Verziótáblázat:
 *** 2.4.2+dfsg2+936+201806302357~ubuntu18.04.1 500
        500 http://ppa.launchpad.net/openshot.developers/ppa/ubuntu bionic/main amd64 Packages
        500 http://ppa.launchpad.net/openshot.developers/ppa/ubuntu bionic/main i386 Packages
        100 /var/lib/dpkg/status
     2.4.1-2build2 500
        500 http://ftp.energotel.sk/pub/linux/ubuntu/archive bionic/universe amd64 Packages
        500 http://ftp.energotel.sk/pub/linux/ubuntu/archive bionic/universe i386 Packages

akkor bizony kis problémába ütközöl.

!Tájékoztatás: sajnos, az újabb openshot-qt csomag telepítése felülírja a korábbi, openshot telepítést, Láttunk már olyat, hogy a PPA-ról vagy más külső forrásból származó csomag nem írja felül a másik verziót, hanem mellé települ és a két verzió párhuzamosan használható (a példa erre a FeeCAD: https://linuxmint.hu/blog/2018/04/a-freecad-017-roland-parametrikus-3d-modellezo-alkalmazas-telepitese), de itt nem ez valósul meg. És a fenti kimenetben úgy érzékelhető, hogy a tárolóból telepíthető OpenShot is telepítve van, pedig nem,

dpkg -L openshot
/.
/usr
/usr/share
/usr/share/doc
/usr/share/doc/openshot
/usr/share/doc/openshot/copyright
/usr/share/doc/openshot/changelog.Debian.gz

mindössze néhány könyvtár maradt belőle. Így akár törölheted is, persze, ha zavar ez a pár megmarad fájl.

sudo apt-get purge openshot

Tehát, ha a tükrökről elérhető csomag nem felel meg valamiért, akkor használd a PPA-t.

Stabil PPA

-- a PPA felvétele

sudo add-apt-repository ppa:openshot.developers/ppa
sudo apt-get update

-- a túl régi függőség eltávolítása

sudo apt-get purge libopenshot14

!Az eltávolítás előtt tesztelj, ne menjen a levesbe valamilyen fontos csomag:

sudo apt-get purge libopenshot14 -s

-- az új függőség telepítése

sudo apt-get install libopenshot15

Az előbbi két lépés nélkül az újabb OpenShot nem indul el, hivatkozva a meglévő régebbi függőségre, de hiába telepíted az újabb függőséget, azt nem érzékeli megfelelően, így a régebbit el kell távolítanod. Igazából a PPA készítőinek dolga lett volna gondoskodni erről a lépésről.

-- jöhet az OpenShot Qt verziójának telepítése:

sudo apt-get install openshot-qt

Magyar kezelői felületre állítva, majd újraindítva a PPA-ról telepített OpenShot így néz ki:

persze, egy kis „csinosítás” után máris szebb a megjelenése. Erről itt olvashatsz:
https://linuxmint.hu/comment/20160#comment-20160

Enjoy :)

-----

Daily PPA

A bátrabbak vagy inkább a merészebbek telepíthetik az OpenShot Daily verzióját,

sudo add-apt-repository ppa:openshot.developers/libopenshot-daily
sudo apt-get update
sudo apt-get install openshot-qt

bár ennek helyes működésére nincs garancia. Nem próbáltam.

Forrás: https://www.openshot.org/ppa/

Appimage

Appimage verzió is elérhető:
https://www.openshot.org/download/
Nem próbáltam.

Kiadási megjegyzések (2.4.2):
https://www.openshot.org/blog/2018/06/30/openshot-242-released-more-effects-more-stable-more-fun/

A PPA-k pontos címe:
(!Fontos: az első PPA a stabil verzió)

... és még egy, az

Hozzászólások

kimarite képe

Openshot+Blender

#5 Köszi.
Használtam az OpenShot-ot, de arról nem volt szó, hogy mindenhez értek a témában. Ez a blog a telepítésről szól, ha szabad „csak” ilyet nyitni persze. :)
Meg sem nyitottam az alkalmazást, mármint „munkára”. ;)

Természetesen nagyon jó, ha a tapasztalataitokkal, tanácsaitokkal segítitek a használatát! Ez is cél.
Mindenről nehéz blogot írni, de eleve nagyon jó leírások léteznek már. :)
És ugye a legtöbb alkalmazás „használata” a telepítéssel kezdődik.

AviDemux-párti vagyok, azt ismerem inkább. Az OpenShot alkalmazást nagyon régen használtam, akkor a célnak megfelelt. Őszintén szólva, feliratok készítésével egyáltalán nem foglalkozom egyik alkalmazásban sem. Ha animált, ha nem. Szerencsére könnyen el tudom képzelni, hogy a Blender miféle segítséget nyújt ebben, mert ilyenekre is jó önmagában is. :)

Értékelés: 

0
Még nincs értékelve

Openshot+Blender

#5.1 Plusz információnak, nem kioktatásnak szántam.

("lazlo" fórumtársunk egy kicsit magába nézhetne.)

Értékelés: 

0
Még nincs értékelve
tonsur képe

Az OpenShot videó szerkesztő alkalmazás telepítési lehetőségei

@#0
Én Ubuntu 18.04.1-en mielött telepitettem volna az Openshot-ot megnéztem,hogy telepitve van-e a libopenshot valamelyik verziója,nem volt,synapticban rendelkezésre állt a libopenshot14,de ugye az nem felel meg a 2.4.2-es verziónak,mivel a libopenshot15 nálam nem telepithető függőségi problémák miatt,és valószinüleg nincs integrálva az appimage-be,ezért az OpenShot-v2.4.2-x86_64.AppImage,el sem indult.A megoldás a kimarite által is irt ppa-s telepités volt,ami minden függőséget is feltelepit, a program a telepitést követően rendben működik. (érdekes,hogy a ppa-s telepités nem csak az újabb libopenshot15-öt telepitette,hanem a régebbi libopenshot14-et is).

Értékelés: 

0
Még nincs értékelve
kimarite képe

Az OpenShot videó szerkesztő alkalmazás telepítési lehetőségei

#6 Akkor az Ubuntu 18.04 ebben más, mint a Linux Mint 19. Mert nálam nem települt:

apt-cache policy libopenshot14
libopenshot14:
  Telepítve: (nincs)
  Jelölt:    0.1.9+dfsg1-3build1
  Verziótáblázat:
     0.1.9+dfsg1-3build1 500
        500 http://ftp.energotel.sk/pub/linux/ubuntu/archive bionic/universe amd64 Packages

Lehet viszont egy másik alkalmazás függősége, bár, ha az újabb csomag telepítése hozta a régebbi csomagot, akkor nemigen. Linux Mint 19 alatt telepítve volt, törölnöm kellett. Lehetett volna linkelni, de nem szükséges csomagnak ítéltem. Én is, a rendszer is.

Habár ezek a kimenetek megtévesztőek:

apt-cache depends libopenshot14
libopenshot14
 |Függ ettől: libavcodec57
  Függ ettől: libavcodec-extra57
  Függ ettől: libavformat57
  Függ ettől: libavresample3
  Függ ettől: libavutil55
  Függ ettől: libc6
  Függ ettől: libgcc1
  Függ ettől: libgomp1
  Függ ettől: libjsoncpp1
  Függ ettől: libmagick++-6.q16-7
  Függ ettől: libmagickcore-6.q16-3
  Függ ettől: libopenshot-audio6
  Függ ettől: libqt5core5a
  Függ ettől: libqt5gui5
  Függ ettől: libqt5widgets5
  Függ ettől: libstdc++6
  Függ ettől: libswscale4
  Függ ettől: libzmq5
apt-cache rdepends libopenshot14
libopenshot14
Reverse Depends:
  libopenshot-dev
  libopenshot15
  python3-openshot

Bár itt már nem:

apt-cache depends libopenshot15
libopenshot15
 |Függ ettől: libavcodec57
  Függ ettől: libavcodec-extra57
  Függ ettől: libavformat57
  Függ ettől: libavresample3
  Függ ettől: libavutil55
  Függ ettől: libc6
  Függ ettől: libgcc1
  Függ ettől: libgomp1
  Függ ettől: libjsoncpp1
  Függ ettől: libmagick++-6.q16-7
  Függ ettől: libmagickcore-6.q16-3
  Függ ettől: libopenshot-audio6
  Függ ettől: libqt5core5a
  Függ ettől: libqt5gui5
  Függ ettől: libqt5widgets5
  Függ ettől: libstdc++6
  Függ ettől: libswscale4
  Függ ettől: libzmq5
  Kicseréli: <libopenshot10>
  Kicseréli: <libopenshot11>
  Kicseréli: <libopenshot12>
  Kicseréli: <libopenshot13>
  Kicseréli: libopenshot14
apt-cache rdepends libopenshot15
libopenshot15
Reverse Depends:
  libopenshot-dev
  python3-openshot

Nem hiányolja a rendszer. Lehet, a biztonsági szintek miatt. Nálam a kettes szintig van engedélyezve.

Értékelés: 

0
Még nincs értékelve