SAMBA nem látható Windows hálózatok között

Laca73 képe

Fórum: 

Sziasztok!

Használtam a keresőt, de annyi SAMBA téma van, hogy nem találtam amit keresek.

Frissen telepített 20.02 Cinnamon van a laptopomon.

SAMBA telepítés után direktben behívva látszik a Linuxos megosztás Windows alól, viszont a Windows hálózatok alatt nem jelenik meg, ami lényeges lenne, mert a kollégák onnan érnék el ami a laptopon van.

A laptop paraméterei ha kellenének.

https://termbin.com/3ptv

Hanyas Windows?

#1

Windows 10 Pro-k vannak a cégnél és kettő Windows 7-es gép amik csak belső hálón futnak speciális szoftverekkel.

Értékelés: 

0
Még nincs értékelve
kimarite képe

Hanyas Windows?

#2 Lehet, hogy például a

client min protocol = NT1

beállítás is elegendő.

https://linuxmint.hu/forum/a-szoftver-kapcsolatmegszakadast-okozott

Ha nem szeretnél nem támogatott protokollt, erre a megoldásra is ránézhetsz.
https://github.com/christgau/wsdd <- a telepítés módszere
https://devanswers.co/discover-ubuntu-machines-samba-shares-windows-10-network/ )

Kihagytak egy lépést. A telepítés (terminálban) a Linux Mint 20.2 kiadáshoz:

echo "deb https://pkg.ltec.ch/public/ focal main" | sudo tee /etc/apt/sources.list.d/christgau:wsdd.list
sudo apt-key adv --fetch-keys https://pkg.ltec.ch/public/conf/ltec-ag.gpg.key
sudo apt-get update
sudo apt-get install wsdd

Értékelés: 

0
Még nincs értékelve

Érdeklődés

Hogyan tudom lekerdezni hogy az Ubuntum smb... ? verziót használ?

Értékelés: 

0
Még nincs értékelve

Hanyas Windows?

#3

Köszönöm, holnap tesztelem is.

Értékelés: 

0
Még nincs értékelve

Hanyas Windows?

#3

Végig zongoráztam a leírtakat, de ezt kapom:

https://paste.ubuntu.com/p/NSbgjdWQSf/

Értékelés: 

0
Még nincs értékelve
kimarite képe

Reason: Unit wsdd.service has a bad unit file setting

#9 Szerkeszd a fájlt:

sudo nano /etc/systemd/system/wsdd.service

Vedd ki megjegyzésből a két sort. Így nézzen ki:

User=nobody 
Group=nobody

Mentsd el:

Ctrl + O, és Enter,
majd Ctrl + X

Majd érvényesítsd  változtatást:

sudo systemctl daemon-reload

Ellenőrizd a szolgáltatás állapotát:

sudo service wsdd status

Értékelés: 

0
Még nincs értékelve

Reason: Unit wsdd.service has a bad unit file setting

#10

 

Nem értem...

Töröljem, a két sort, vagy a pontosvesszőt vegyem ki előle?

Értékelés: 

0
Még nincs értékelve
kimarite képe

Reason: Unit wsdd.service has a bad unit file setting

#11 A ; vagy a # a megjegyzés (komment) a sor (beállítás) elején. Ha látod valamelyiket, akkor a sorban látható beállítást a rendszer nem használja. Tehát, hogy használd a beállításokat, törölni kell a ; karaktert (és szóköz se maradjon) a sorok elejéről. A többi ugyanaz marad.

Értékelés: 

0
Még nincs értékelve

Reason: Unit wsdd.service has a bad unit file setting

#12

Meg csináltam, de amikor bele néztem mentés után, ugyanúgy ki kommentelve mutatja.

Értékelés: 

0
Még nincs értékelve
kimarite képe

Reason: Unit wsdd.service has a bad unit file setting

#13 Akkor állítsd le a folyamatot először, és utána szerkeszd a fájlt.

sudo service wsdd stop

Használtad a gyorsbillentyűket a mentéshez?

Ctrl + O, és Enter,
majd Ctrl + X

Ctrl + O és Ctrl + X -> egyszerre nyomd meg (lehet, tudod).

Értékelés: 

0
Még nincs értékelve

Reason: Unit wsdd.service has a bad unit file setting

#14

Sikerült mentenem, de a hiba ugyanaz.

https://paste.ubuntu.com/p/DMGDHp6m5Z/

Értékelés: 

0
Még nincs értékelve
kimarite képe

Reason: Unit wsdd.service has a bad unit file setting

#16 De ezt a három lépést is nézd át:
https://forums.linuxmint.com/viewtopic.php?p=1038679#p1038679

A szöveg (részlet) pedig így lenne mégis, plusz egy új sor:

[Service]
Type=simple
ExecStartPre=/bin/sleep 2
ExecStart=/usr/bin/wsdd --shortlog
; Replace those with an unprivledged user/group that matches your environment,
; like nobody/nogroup or daemon:daemon or a dedicated user for wsdd
#User=nobody
#Group=nobody

Értékelés: 

0
Még nincs értékelve

Reason: Unit wsdd.service has a bad unit file setting

#17

Köszönöm a segítséget, sikerült megoldani! :)

Értékelés: 

0
Még nincs értékelve