Mate üdvözlőhang bejelentkezéskor ? [ MEGOLDVA ]

Fórum: 

Üdv mindenkinek!

Szeretném kérdezni, hogy a 17.3 Mate -ban van-e üdvözlőhang a rendszer betöltésekor? És ha igen akkor hogyan kell azt bekapcsolni?

Ha KDE -vel indítom akkor van, ha MATE -vel akkor nincs.

IBM Thinkpad R40 Intel 1300Mhz 512MB 40GB

RE: MATE, üdvözlőhang bejelentkezéskor?

@#0 Szia! Az /usr/share/sounds könyvtárban találtam egy ilyen fájlt: linuxmint-login.wav
Az Indítópulthoz (Applications/Preferences/Startup Applications) hozzáadtam egy újat:
Név (Name): Üdvözlőhang
Parancs (Command): play /usr/share/sounds/linuxmint-login.wav

(Elnézést a zárójelezett angol elnevezésekért, de Live rendszer alól néztem, és nekem a magyar elnevezések nem álltak rendelkezésemre, lehet, hogy nem pontosan így szerepelnek a rendszeredben, csak megtippeltem őket, ezért odaírtam melléjük az  általam a képernyőn látott angolt is. Remélem, azért így is eligazodsz rajta!)

Értékelés: 

5
Átlag: 5 (2 szavazat)
kimarite képe

MATE vagy Cinnamon

https://community.linuxmint.com/tutorial/view/1256

Azt írja egy válaszoló, a 17.2-nél is működik a bejelentkezéskori hang;

     - MATE

Go to System>Preferences>Startup Applications
and added "GNOME Login Sound" with the following description:
-- Az 'Automatikusan induló alkalmazások' beállításnál 'Gnome bejelentkezési hang' vagy ..., Hang lejátszása a bejelentkezéskor' néven adj egy indítót az alábbi beállításokkal.

Name:           GNOME Login Sound
                (az indító elnevezése, ám az angol helyett ..., lásd fentebb)
Command:        paplay /usr/share/sounds/LinuxMint/stereo/desktop-login.ogg
                (parancs, ez 'csinálja', azt amit ...)
Comment:        Plays a sound whenever you log in
                (mi ez, mit csinál; leírás, emlékeztető magyarázat)

to test sound in terminal, run:
(teszt, az alábbi parancsot terminálba másolva és futtatva, kiderül, működik-e majd az indító. ha hangot hallasz, akkor igen .. :) )

paplay /usr/share/sounds/LinuxMint/stereo/desktop-login.ogg

     - Cinnamon
(a magyar nyelvű magyarázatot lásd fentebb)

Go to System>Preferences>Startup Applications and added "GNOME Login Sound" with the following description:

Name:           GNOME Login Sound
Command:        /usr/bin/canberra-gtk-play --id="desktop-login" --description="GNOME Login"
Comment:        Plays a sound whenever you log in

to test sound in terminal, run:

/usr/bin/canberra-gtk-play --id="desktop-login" --description="GNOME Login"

Értékelés: 

5
Átlag: 5 (1 szavazat)
kimarite képe

RE:RE: MATE, üdvözlőhang bejelentkezéskor?

#3 Az előbb említett megoldással mennie kéne a logout-nak is,
https://forums.linuxmint.com/viewtopic.php?t=130356
de mi van, ha megpróbálod jelszavas bejelentkezésre változtatni a belépésed az automatikusról?
https://bugs.launchpad.net/linuxmint/+bug/1164802

Kijelentkező hangod is van?

paplay /usr/share/sounds/LinuxMint/stereo/desktop-logout.ogg

Értékelés: 

0
Még nincs értékelve
kimarite képe

RE:RE:RE: MATE, üdvözlőhang bejelentkezéskor?

#4 Milyen display-manager-t használsz?
( a sudo tilos a pluma-val .. : http://forums.mate-desktop.org/viewtopic.php?f=2&t=3385 )

cat /etc/X11/default-display-manager

Ez a kijelentkező hang meglepően aranyos .., ha nem lenne. :)
http://linuxmint-art.org/content/show.php/Cinnamon+logout+sound?content=...
( az eredetit nem kell törölni, elég átnevezni a végén így *.ORIG )

Értékelés: 

0
Még nincs értékelve

RE:RE:RE:RE: MATE, üdvözlőhang bejelentkezéskor?

#5 Ok. köszönöm!

Próbálgatok :)

Miért is kell nekem display-manager ? Hú nagyon kezdő vagyok :D

Értékelés: 

0
Még nincs értékelve

RE:RE:RE: MATE, üdvözlőhang bejelentkezéskor?

#4 Időközben megtaláltam a kijelentkező hangot is, beállítottam, de az a probléma, hogy azt is a bejelentkezéskor játsza le :) . Az automatikus bejelentkezést meg nem tudom beállítani, mert egy remaster verzón próbálkozok és valami hiba csúszott be a remaster elkészítésekor, így most csak a jelszavas belépést engedi. Sajnos átállítani sem tudom :(

Értékelés: 

0
Még nincs értékelve
kimarite képe

RE:RE:RE:RE: MATE, üdvözlőhang bejelentkezéskor?

#7 Nem azt mondtam, hogy ugyanúgy kell beállítani a kijelentkezéskor lejátszott hangot, mint a bejelentkezéskorit :). Mert, ha ugyanúgy állítod be (a rendszer indítására, azzal együtt indítod), akkor persze, hogy akkor játssza le. Kicsit gondolkozz.
Azt mondtam, hogy azt írják, a bejelentkező hang beállítása magával hozza, megjavítja a kijelentkezéskori hangot, azzal külön nem kell foglakozni. Amúgy az, hogy mondod 'beállítottam', nekem -és szerintem másnak is- csak annyit mond, hogy vettem két kiló krumplit. Abból lehet sült, főtt vagy akármi, krumpli bábu is (általános közlés). Mit állítottál be pontosan és hogyan (a kijelentkező hang tekintetében)?
A Display managerek többsége a bejelentkezést is vezérli .. .

Értékelés: 

0
Még nincs értékelve

RE:RE:RE:RE:RE: MATE, üdvözlőhang bejelentkezéskor?

#8 Szia!

Gondolkozok folyamatosan, de sokat kell még tanulnom :)

Az indítópultben hozzáadtam az alábbi parancsot is :

paplay /usr/share/sounds/LinuxMint/stereo/desktop-logout.ogg


Értékelés: 

0
Még nincs értékelve

RE:RE:RE:RE:RE:RE: MATE, üdvözlőhang bejelentkezéskor?

#9 Ami az indítópanelhez (Indítópult?) hozzá van adva, azt a gép a felhasználó fiókba történő bejelentkezésekor elindítja.
Ha ide beteszed a Skype-ot, akkor bejelentkezéskor automatikusan el fog indulni. Ha beteszed, hogy játsza le az üdvözlőhangot, akkor lejátsza.

Értékelés: 

0
Még nincs értékelve

RE:RE:RE:RE:RE:RE:RE: MATE, üdvözlőhang bejelentkezéskor?

#10 Indítópult -> "Automatikusan elinduló programok" legalábbis a Magyar nyelvi csomagok letöltése után így jelenik meg. Ez eddig tiszta sor. A bejelentkező hang mostmár működik, de kijelentkező hang nem akar megszólalni még.

Értékelés: 

0
Még nincs értékelve
kimarite képe

RE:RE:RE:RE:RE:RE:RE:RE: MATE, üdvözlőhang bejelentkezéskor?

#11 Hamarosan megpróbáljuk megoldani; de amit az indítópultba teszel, az az indításkor 'történik meg'.

Értékelés: 

0
Még nincs értékelve

RE:RE:RE:RE:RE:RE:RE:RE:RE: MATE, üdvözlőhang bejelentkezéskor?

#12 Ok. köszi!

Végül is nem létkérdés, ha nem lenne az sem a világ vége, e-nélkül nem fogok áttérni a másik oldalra :)

Egyébként gondoltam egy olyanra, hogy amikor megnyomom a kikapcsoló gombot, a gomb parancsa elébe beírom a hang lejátszásának a parancsát, de nem találom sehol a gomb tulajdonságait, ahová belehetne írni. De az is lehet, hogy tévúton járok.

Értékelés: 

0
Még nincs értékelve
kimarite képe

...: MATE, üdvözlőhang bejelentkezéskor?

#13 Pontosan erre gondolok én is:
(a szerkesztendő konfigot persze, meg kell keresni)

- kikapcsoláskor

paplay /usr/share/sounds/LinuxMint/stereo/desktop-logout.ogg && sudo shutdown -h now

- rendszer újraindításkor

paplay /usr/share/sounds/LinuxMint/stereo/desktop-logout.ogg && sudo shutdown -r now

- kijelentkezés (szkript)
https://forums.linuxmint.com/viewtopic.php?t=177547

#!/bin/bash
TEMP1=`who | grep user_to_log_out | grep tty | awk '{ print $5 }'`
export DISPLAY=`echo "${TEMP1:1:${#string}-1}"`
cinnamon-session-quit --logout --force

Hanggal

#!/bin/bash TEMP1=`who | grep user_to_log_out | grep tty | awk '{ print $5 }'`
export DISPLAY=`echo "${TEMP1:1:${#string}-1}"`
paplay /usr/share/sounds/LinuxMint/stereo/desktop-logout.ogg && cinnamon-session-quit --logout --force

Ja, a környezet nem Cimmanon, hanem MATE. :)
Ez a szkriptnél érdekes csak.

Értékelés: 

0
Még nincs értékelve

RE:...: MATE, üdvözlőhang bejelentkezéskor?

#16 Próbálokozok :)

Lehet, hogy hülyeség, de most az jutott eszembe, hogy léterhozok egy alkalmazás indító gombot a panelre, társítok hozzá egy kikapcsológomb ikont és hozzáadom:

paplay /usr/share/sounds/linuxmint/stereo/desktop-logout.ogg && logout && sudo shutdown -h now

de valamiért nem működik

Ha csak ennyit írok be:

paplay /usr/share/sounds/linuxmint/stereo/desktop-logout.ogg

akkor a hang működik.

 

Értékelés: 

0
Még nincs értékelve
kimarite képe

MATE; elköszönő hang kijelentkezéskor

#17 Nem vagyok biztos ebben, de a 'logout' elé nem kéne egy 'sudo', azaz csak oda?

Illetve az időzítés számodra most jótékony hatása miatt a parancsikonban (szkript) szereplő sort inkább így próbálva,

paplay /usr/share/sounds/linuxmint/stereo/desktop-logout.ogg && sudo logout && shutdown -h now

biztató eredményre lelsz, azaz működni fog.

Értékelés: 

0
Még nincs értékelve
csavi képe

Csak egy link hozzá

Csak egy linket hoztam ehhez. Valamikor régebben még az Ubuntuhoz kerestem rá. Ott van, mit is kell az indítópulthoz hozzá adni de megtalálható a terminálos parncs sor is hozzá.

www.techlw.com/2012/06/enable-login-sound-in-ubuntu-1204.html

Értékelés: 

4
Átlag: 4 (1 szavazat)

RE:MATE; elköszönő hang kijelentkezéskor

#18

Nálam valamiért nem működik. Végül is a bejelentkező hang az megoldódott, kijelentkező hang nélkül meg meg lehet lenni :)

Azért köszönöm mindenkinek a segítséget!

Értékelés: 

0
Még nincs értékelve
kimarite képe

RE:RE:MATE; elköszönő hang kijelentkezéskor

#20 De mit tapasztalsz a parancs kiadásakor?

És így?

paplay /usr/share/sounds/linuxmint/stereo/desktop-logout.ogg && sudo shutdown -h now

Értékelés: 

0
Még nincs értékelve

Szóval ha terminálba írom be

Szóval ha terminálba írom be akkor lejátsza a hangot, de nem kapcsol ki. Ha a panelre teszek egy indítóikont és a parancshoz írom be, akkor nem csinál semmit.

Értékelés: 

0
Még nincs értékelve
kimarite képe

RE:Szóval ha terminálba írom be

#22 Két dologgal kell 'kezdeni' valamit;
-- miért nem kapcsol ki a rendszered a 'sudo shutdown -h now' parancsra (önmagában és terminálban futtatva kikapcsol?)
-- a parancsikont -azt hittem- úgy készítetted el, hogy terminálban fusson le, ezek szerint nem ...
(később tudok erre válaszolni, de a parancsikonod szöveges tartalma kéne és az is kérdés, hogy futtathatóvá tetted?

Értékelés: 

0
Még nincs értékelve

RE:RE:Szóval ha terminálba írom be

#23 Ha terminálba beírom a 'sudo shutdown -h now' parancsot , akkor bekéri a jelszót és kikapcsol. De ha más parancsal kombinálom akkor nem.

Ha tálca indító ikont készítek simán , akkor nem történik semmi, ha "Alkalmazás terminálban" -t is bejelölöm, akkor azt írja ki, hogy Nincs ilyen fájl vagy könyvtár. Az alkalmazás indírása sikertelen.

Az is lehet, hogy már úgy elbabráltam a rendszeret, hogy amiatt nem jön össze a dolog, ha lesz egy kis időm és persze türelmem akkor újra teszem a rendszert utána újból megpróbálom.

Értékelés: 

0
Még nincs értékelve
kimarite képe

RE:RE:RE:Szóval ha terminálba írom be

#24 'Ha tálca indító ikont készítek simán'

Mi ennek a szöveges tartalma? .. egyszer már kérdeztem.
Futtathatóvá tetted? - valószínű, ha visszajelez ..,
ám kéne inkább egy

ls -la

kimenet.

Értékelés: 

0
Még nincs értékelve

RE:RE:RE:RE:Szóval ha terminálba írom be

#25

Bocs, hogy csak most jelentkezek, de meglehetősen sűrű volt számomra az elmúlt időszak, így nem tudtam foglalkozni a dologgal mostanában.

Szóval újra telepítettem a gépet, sok apró dolog helyére került.

Bejelentkező hang egyből lett , ha az indítópulthoz hozzá adtam a

paplay /usr/share/sounds/LinuxMint/stereo/desktop-login.ogg

Terminálból működik a kijelentkező hang is a 

paplay /usr/share/sounds/LinuxMint/stereo/desktop-logout.ogg && sudo shutdown -h now

parancs kiadásakor. Tehát így van kijelentkező hang és ki is kapcsol a gép.

A tálcára tett indítóikonnal nem tudtam megoldani, nem látok olyan lehetőséget, hogy futtathatóvá tétel.

Az alap kérdés végül is megoldódott, van bejelentkező hangom :)

Mégegyszer köszönöm mindenkienk a segítséget.

Értékelés: 

0
Még nincs értékelve
kimarite képe

RE:RE:RE:RE:RE:Szóval ha terminálba írom be

#26 'A tálcára tett indítóikonnal nem tudtam megoldani, nem látok olyan lehetőséget, hogy futtathatóvá tétel.'

Kell egy szkript (máshogyan is meg lehet oldani)

-- elkészítés

touch shutdownandsound_script

-- megnyitod szerkesztésre

nano shutdownandsound_script

-- bele

#!/bin/bash
paplay /usr/share/sounds/LinuxMint/stereo/desktop-logout.ogg && sudo shutdown -h now

-- mented; Ctrl + Alt + O és Enter
-- bezárod a nano szerkesztőt; Ctrl + Alt +X

-- futtathatóvá teszed

chmod +x shutdownandsound_script

-- átmásolod egy megfelelő helyre

sudo mv shutdownandsound_script /usr/local/bin/

A desktop ikon (parancsikon)

-- helye (elkészítése ..)

sudo touch /usr/local/share/applications/shutdownandsound.desktop

-- szerkesztése

sudo nano/usr/local/share/applications/shutdownandsound.desktop

[...]

-- tartalma

[Desktop Entry]
Version=1.0
Name=Leállítás viszlát hanggal
Type=Application
Comment=Rendszer hack
Terminal=true
Exec=/usr/local/bin/shutdownandsound_script
Icon=/usr/share/icons/shutdownandsound
Categories=ConsoleOnly;System;
GenericName=Rendszer kikapcsolása

Az -tetszőleges, neked megfelelő- ikon-t (kép) neked kell betenni a 'helyére' (könyvtár) vagy használhatsz rendszer ikon is.

Felhasznált irodalom;
http://askubuntu.com/questions/189324/how-to-run-terminal-script-by-clic...
http://askubuntu.com/questions/60667/apply-icons-to-bash-scripts/60670#6...

A '*.desktop' fájlt nem kell futtathatóvá tenni.

Értékelés: 

0
Még nincs értékelve

RE:RE:RE:RE:RE:RE:Szóval ha terminálba írom be

#27 -- helye, ( elkészítése .. ) -nél elakadtam

sudo touch /usr/local/share/applications/shutdownandsound.desktop

beírása után azt írja ki, hogy Nincs ilyen fájl vagy könyvtár

Értékelés: 

0
Még nincs értékelve
kimarite képe

RE:RE:RE:RE:RE:RE:RE:Szóval ha terminálba írom be

#28 Azért én oda tenném, ahova .. kell.
Létezik-e neked az előbbi parancsban szereplő könyvtár (a listázás mutatja),
# ez egy kérdés :), mi a kimenet?

ls /usr/local/share/applications

ha nem, létre kéne hozni.

Nálam is ott vannak az általam, a nem megszokott módon telepített alkalmazások indítói;

ls /usr/local/share/applications/
audacious.desktop  mimeinfo.cache  mpv.desktop  xfburn.desktop

de egyébként a UNIX szerint kell oda tenni, ahova írtam (local).

Értékelés: 

0
Még nincs értékelve
kimarite képe

RE:RE:RE:RE:RE:RE:RE:RE:Szóval ha terminálba írom be

#29 ... mert a 'local' az te vagy, azaz amit te, mint felhasználó létrehozol (sk)

sudo find /usr/local/ -type d -name 'applications'
/usr/local/share/applications

és a rendszer a félkövérrel jelzett könyvtárban hoz létre indítókat...

sudo find /usr/share/ -type d -name 'applications'
/usr/share/gnome/applications
/usr/share/applications
/usr/share/winetricks/applications

Ha lehet, ne keverjük.

Előbb két 'megoldásnál' a parancsikonokat felhasználók összessége,
alábbi könyvtárba tett indítókat csak egy felhasználó 'látja' és használhatja;

sudo find /home/$USER/ -type d -name 'applications'
/home/cave/jd2/jre/lib/desktop/applications
/home/cave/live-default/chroot/usr/share/applications
/home/cave/live-default/cache/bootstrap/usr/share/applications
/home/cave/.local/share/applications

vagyis az adott felhasználói könyvtár tulajdonosa és (fel)használója.
Ha több felhasználó is létezik, akkor az ide tett indítók tekintetében
~/.local/share/applications/
ezt jó tudni. (de nem ezt mondtam az imént, ez tájékoztatás)

Értékelés: 

0
Még nincs értékelve

Nem volt applications mappa,

Nem volt applications mappa, létrehoztam.

Így tovább jutottam, de a

sudo nano/usr/local/share/applications/shutdownandsound.desktop

parancs kiadása után azt írja, hogy: "command not found"

Értékelés: 

0
Még nincs értékelve

RE:Nem volt applications mappa,

#31  A nano után kellene egy szóköz.

sudo-szóköz-nano-szóköz-per-usr-per...

Értékelés: 

0
Még nincs értékelve
kimarite képe

RE:Nem volt applications mappa,

#31 Ha az ez előtti parancsokat is véghezvitted, akkor másold ezt a parancsot.

sudo nano /usr/local/share/applications/shutdownandsound.desktop

És jönet a vázolt következő lépés, a szöveg bemásolás, majd mentése ...

A terminálba -ból a legegyszerűbb az egérrel másolni.
Kijelölöd az itt szereplő szöveget, például a parancssort (másolod; Ctlr + C), majd a megnyitott terminál ablakába viszed az egér mutatót, és az egér jobblikkes menüvel 'beilleszted'. A szóközök fontosak, de csak ott ahol kell.

sudo - emelt jogot biztosító parancs (terminálos alkalmazásokhoz és alkalmazásokhoz)
nano - a szövegszerkesztő
/usr/local/share/applications/ - a könyvtár (könyvtárszerkezet vagy másként elérési út), ahol a szerkeszteni való fájl van
shutdownandsound.desktop - a szerkeszteni való fájlt (de itt nem kell szóköz), mert ...
/usr/local/share/applications/shutdownandsound.desktop - a fájlt az elérési úton megnyitva szerkeszted, de ..
cd /usr/local/share/applications/ - beléphetnél elöször a könyvtárba [change directory parancs; cd], ahol a fájl van (létrehoztad), majd ...
sudo nano shutdownandsound.desktop - már a könyvtárban állva is szerkeszted

A change directory parancsot talán ahhoz lehet hasonlítani, amikor a Keleti pályaudvaron megkérdezi tőled egy feketén pénzt váltó ember, hogy; Change money? (akarsz pénzt váltani?) ... itt könyvtárakat váltasz, de lépeghetnél is bennük 'fel- és le' a 'cd' paranccsal. Előbbi példánál csak beléptél egybe. Mert a könyvtárak egymás alatt (és fölött) helyezkednek el -persze egymás mellett is- ezt könyvtárfának is hívják. Ha kiadod a

tree

parancsot, látod is a 'fát' (angolul tree; mely a másik, a 'pstree' parancsnál 'process' fa volt, azaz folyamatok fa). Ha megunod, nem várnál a befejezésig, nyomj Ctrl + C -t, megszakítja a folyamatot.
A linux parancsok általában egyszerűen megérthető rövidítések.
Próbáld újra a parancsot.

Értékelés: 

0
Még nincs értékelve

RE:RE:Nem volt applications mappa,

#33 Megcsináltam! Működik :)

Köszi mindenkinek!

Értékelés: 

0
Még nincs értékelve